The site is under maintenance.

Most probably the CPANTS databases are being regenerated from scratch behind the scenes due to the major change in Kwalitee metrics or the update of relevant modules/perl. Usually this maintenance takes about a day or two, and some of the information may be old or missing tentatively. Sorry for the inconvenience.

Apache2-AuthColloquy

Metadata

Analyzed metadata and errors of Apache2-AuthColloquy.

{
   "abstracts" : {
      "Apache2::AuthColloquy" : "mod_perl authentication against the Colloquy users.lua file"
   },
   "author" : "NICOLAW",
   "buildfile_executable" : 0,
   "dir_lib" : "lib",
   "dir_t" : "t",
   "dirs_array" : [
      "lib",
      "lib/Apache2",
      "t"
   ],
   "dist" : "Apache2-AuthColloquy",
   "dynamic_config" : 0,
   "easily_repackageable_by_fedora" : "fits_fedora_license",
   "error" : {
      "use_warnings" : "Apache2::AuthColloquy"
   },
   "extension" : "tar.gz",
   "external_license_file" : "LICENSE",
   "extractable" : 1,
   "extracts_nicely" : 1,
   "file__build" : 0,
   "file_blib" : 0,
   "file_build" : 0,
   "file_build_pl" : "Build.PL",
   "file_changelog" : "Changes",
   "file_license" : "LICENSE",
   "file_makefile" : 0,
   "file_makefile_pl" : "Makefile.PL",
   "file_manifest" : "MANIFEST",
   "file_meta_yml" : "META.yml",
   "file_pm_to_blib" : 0,
   "file_readme" : "README",
   "files_array" : [
      "README",
      "Build.PL",
      "NOTICE",
      "Changes",
      "INSTALL",
      "Makefile.PL",
      "META.yml",
      "MANIFEST",
      "LICENSE",
      "lib/Apache2/AuthColloquy.pm",
      "t/01pod.t",
      "t/00compile.t",
      "t/02pod_coverage.t"
   ],
   "files_hash" : {
      "Build.PL" : {
         "mtime" : 1142867204,
         "required_in_eval" : [
            "Config",
            "LWP::UserAgent"
         ],
         "size" : 2510,
         "used" : [
            "Module::Build",
            "strict",
            "vars"
         ]
      },
      "Changes" : {
         "mtime" : 1142867204,
         "size" : 1217
      },
      "INSTALL" : {
         "mtime" : 1142867204,
         "size" : 45
      },
      "LICENSE" : {
         "mtime" : 1142867204,
         "size" : 11358
      },
      "MANIFEST" : {
         "mtime" : 1142867204,
         "size" : 169
      },
      "META.yml" : {
         "mtime" : 1142867204,
         "size" : 594
      },
      "Makefile.PL" : {
         "mtime" : 1142867204,
         "required" : [
            "CPAN",
            "Cwd",
            "ExtUtils::MakeMaker",
            "File::Spec",
            "Module::Build"
         ],
         "size" : 1109,
         "used" : [
            "lib"
         ],
         "used_in_eval" : [
            "Module::Build::Compat"
         ]
      },
      "NOTICE" : {
         "mtime" : 1142867204,
         "size" : 89
      },
      "README" : {
         "mtime" : 1142867204,
         "size" : 1211
      },
      "lib/Apache2/AuthColloquy.pm" : {
         "module" : "Apache2::AuthColloquy",
         "mtime" : 1142867204,
         "required" : [
            "Apache2::Access",
            "Apache2::Connection",
            "Apache2::Log",
            "Apache2::RequestRec",
            "Apache2::RequestUtil",
            "Exporter"
         ],
         "size" : 4994,
         "used" : [
            "Apache2::Const",
            "Colloquy::Data",
            "MD5",
            "mod_perl2",
            "strict",
            "vars"
         ]
      },
      "t/00compile.t" : {
         "mtime" : 1142867204,
         "size" : 207,
         "used" : [
            "Test::More",
            "lib"
         ]
      },
      "t/01pod.t" : {
         "mtime" : 1142867204,
         "size" : 129,
         "used" : [
            "Test::More"
         ],
         "used_in_eval" : [
            "Test::Pod"
         ]
      },
      "t/02pod_coverage.t" : {
         "mtime" : 1142867204,
         "size" : 243,
         "used" : [
            "Test::More"
         ],
         "used_in_eval" : [
            "Test::Pod::Coverage"
         ]
      }
   },
   "got_prereq_from" : "META.yml",
   "kwalitee" : {
      "buildtool_not_executable" : 1,
      "consistent_version" : 1,
      "easily_repackageable_by_debian" : 1,
      "easily_repackageable_by_fedora" : 0,
      "extractable" : 1,
      "extracts_nicely" : 1,
      "fits_fedora_license" : 0,
      "has_abstract_in_pod" : 1,
      "has_buildtool" : 1,
      "has_changelog" : 1,
      "has_human_readable_license" : 1,
      "has_known_license_in_source_file" : 0,
      "has_license_in_source_file" : 1,
      "has_manifest" : 1,
      "has_meta_yml" : 1,
      "has_proper_version" : 1,
      "has_readme" : 1,
      "has_separate_license_file" : 1,
      "has_tests" : 1,
      "has_tests_in_t_dir" : 1,
      "has_version" : 1,
      "kwalitee" : "92.68",
      "manifest_matches_dist" : 1,
      "metayml_conforms_to_known_spec" : 1,
      "metayml_declares_perl_version" : 0,
      "metayml_has_license" : 1,
      "metayml_has_provides" : 1,
      "metayml_is_parsable" : 1,
      "no_abstract_stub_in_pod" : 1,
      "no_broken_auto_install" : 1,
      "no_broken_module_install" : 1,
      "no_dot_dirs" : 1,
      "no_dot_underscore_files" : 1,
      "no_generated_files" : 1,
      "no_invalid_versions" : 1,
      "no_local_dirs" : 1,
      "no_mymeta_files" : 1,
      "no_pax_headers" : 1,
      "no_pod_errors" : 1,
      "no_stdin_for_prompting" : 1,
      "no_symlinks" : 1,
      "package_version_matches_dist_version" : 1,
      "portable_filenames" : 1,
      "proper_libs" : 1,
      "use_strict" : 1,
      "use_warnings" : 0,
      "valid_signature" : 1
   },
   "latest_mtime" : 1142867204,
   "license" : "open_source defined in META.yml defined in LICENSE",
   "license_from_yaml" : "open_source",
   "license_in_pod" : 1,
   "manifest_matches_dist" : 1,
   "meta_yml" : {
      "abstract" : "mod_perl authentication against the Colloquy users.lua file",
      "author" : [
         "Nicola Worthington <nicolaw@cpan.org>"
      ],
      "build_requires" : {
         "Test" : "0",
         "Test::More" : "0",
         "Test::Pod" : "0",
         "Test::Pod::Coverage" : "0"
      },
      "generated_by" : "Module::Build version 0.2611",
      "license" : "open_source",
      "meta-spec" : {},
      "name" : "Apache2-AuthColloquy",
      "provides" : {
         "Apache2::AuthColloquy" : {
            "file" : "lib/Apache2/AuthColloquy.pm",
            "version" : "1.13"
         }
      },
      "requires" : {
         "Apache2::Access" : "0",
         "Apache2::Connection" : "0",
         "Apache2::Const" : "0",
         "Apache2::Log" : "0",
         "Apache2::RequestRec" : "0",
         "Apache2::RequestUtil" : "0",
         "Colloquy::Data" : "1.02",
         "MD5" : "0",
         "mod_perl2" : "0"
      },
      "version" : "1.13"
   },
   "metayml_is_parsable" : 1,
   "modules" : [
      {
         "file" : "lib/Apache2/AuthColloquy.pm",
         "in_basedir" : 0,
         "in_lib" : 1,
         "module" : "Apache2::AuthColloquy"
      }
   ],
   "no_pax_headers" : 1,
   "package" : "Apache2-AuthColloquy-1.13.tar.gz",
   "prereq" : [
      {
         "is_prereq" : 1,
         "requires" : "mod_perl2",
         "type" : "runtime_requires",
         "version" : "0"
      },
      {
         "is_prereq" : 1,
         "requires" : "Apache2::Const",
         "type" : "runtime_requires",
         "version" : "0"
      },
      {
         "is_prereq" : 1,
         "requires" : "Apache2::Log",
         "type" : "runtime_requires",
         "version" : "0"
      },
      {
         "is_prereq" : 1,
         "requires" : "Apache2::RequestUtil",
         "type" : "runtime_requires",
         "version" : "0"
      },
      {
         "is_build_prereq" : 1,
         "requires" : "Test",
         "type" : "build_requires",
         "version" : "0"
      },
      {
         "is_build_prereq" : 1,
         "requires" : "Test::Pod::Coverage",
         "type" : "build_requires",
         "version" : "0"
      },
      {
         "is_prereq" : 1,
         "requires" : "Colloquy::Data",
         "type" : "runtime_requires",
         "version" : "1.02"
      },
      {
         "is_prereq" : 1,
         "requires" : "Apache2::Access",
         "type" : "runtime_requires",
         "version" : "0"
      },
      {
         "is_build_prereq" : 1,
         "requires" : "Test::Pod",
         "type" : "build_requires",
         "version" : "0"
      },
      {
         "is_build_prereq" : 1,
         "requires" : "Test::More",
         "type" : "build_requires",
         "version" : "0"
      },
      {
         "is_prereq" : 1,
         "requires" : "MD5",
         "type" : "runtime_requires",
         "version" : "0"
      },
      {
         "is_prereq" : 1,
         "requires" : "Apache2::Connection",
         "type" : "runtime_requires",
         "version" : "0"
      },
      {
         "is_prereq" : 1,
         "requires" : "Apache2::RequestRec",
         "type" : "runtime_requires",
         "version" : "0"
      }
   ],
   "released_epoch" : 1142867308,
   "size_packed" : 8608,
   "size_unpacked" : 23875,
   "unknown_license_texts" : {
      "lib/Apache2/AuthColloquy.pm" : "=head1 COPYRIGHT\n\nCopyright 2005,2006 Nicola Worthington.\n\nThis software is licensed under The Apache Software License, Version 2.0.\n\nL<http://www.apache.org/licenses/LICENSE-2.0>\n\n"
   },
   "uses" : {
      "required_in_code" : {
         "Apache2::Access" : 1,
         "Apache2::Connection" : 1,
         "Apache2::Log" : 1,
         "Apache2::RequestRec" : 1,
         "Apache2::RequestUtil" : 1,
         "Exporter" : 1
      },
      "required_in_config" : {
         "CPAN" : 1,
         "Cwd" : 1,
         "ExtUtils::MakeMaker" : 1,
         "File::Spec" : 1,
         "Module::Build" : 1
      },
      "required_in_eval_in_config" : {
         "Config" : 1,
         "LWP::UserAgent" : 1
      },
      "used_in_code" : {
         "Apache2::Const" : 1,
         "Colloquy::Data" : 1,
         "MD5" : 1,
         "mod_perl2" : 1,
         "strict" : 1,
         "vars" : 1
      },
      "used_in_config" : {
         "Module::Build" : 1,
         "lib" : 1,
         "strict" : 1,
         "vars" : 1
      },
      "used_in_eval_in_config" : {
         "Module::Build::Compat" : 2
      },
      "used_in_eval_in_tests" : {
         "Test::Pod" : 1,
         "Test::Pod::Coverage" : 1
      },
      "used_in_tests" : {
         "Test::More" : 3,
         "lib" : 1
      }
   },
   "valid_signature" : -1,
   "version" : "1.13",
   "versions" : {
      "lib/Apache2/AuthColloquy.pm" : {
         "Apache2::AuthColloquy" : "1.13"
      }
   },
   "vname" : "Apache2-AuthColloquy-1.13"
}