Kwalitee Issues

use_strict

Add 'use strict' (or its equivalents) to all modules, or convince us that your favorite module is well-known enough and people can easily see the modules are strictly written.

Error: GnuPG::Tie::ClearSign, GnuPG::Tie::Decrypt, GnuPG::Tie::Encrypt, GnuPG::Tie::Sign

has_tests_in_t_dir

Add tests or move tests.pl to the t/ directory!

meta_yml_declares_perl_version

If you are using Build.PL define the {requires}{perl} = VERSION field. If you are using MakeMaker (Makefile.PL) you should upgrade ExtUtils::MakeMaker to 6.48 and use MIN_PERL_VERSION parameter. Perl::MinimumVersion can help you determine which version of Perl your module needs.

meta_yml_has_license

Define the license if you are using in Build.PL. If you are using MakeMaker (Makefile.PL) you should upgrade to ExtUtils::MakeMaker version 6.31.

use_warnings

Add 'use warnings' (or its equivalents) to all modules (this will require perl > 5.6), or convince us that your favorite module is well-known enough and people can easily see the modules warn when something bad happens.

Error: GnuPG, GnuPG::Tie, GnuPG::Tie::ClearSign, GnuPG::Tie::Decrypt, GnuPG::Tie::Encrypt, GnuPG::Tie::Sign

meta_yml_has_provides

Add all modules contained in this distribution to the META.yml field 'provides'. Module::Build or Dist::Zilla::Plugin::MetaProvides do this automatically for you.

meta_yml_has_repository_resource

Add a 'repository' resource to the META.yml via 'meta_add' accessor (for Module::Build) or META_ADD parameter (for ExtUtils::MakeMaker).

Modules

Name Abstract Version View
GnuPG Perl module interface to the GNU Privacy Guard (v1.x.x series) 0.19 metacpan
GnuPG::Tie metacpan
GnuPG::Tie::ClearSign metacpan
GnuPG::Tie::Decrypt metacpan
GnuPG::Tie::Encrypt Tied filehandle interface to encryption with the GNU Privacy Guard. metacpan
GnuPG::Tie::Sign metacpan

Other Files

ChangeLog metacpan
MANIFEST metacpan
META.json metacpan
META.yml metacpan
Makefile.PL metacpan
README metacpan