Kwalitee Issues

meta_yml_is_parsable

Upgrade your YAML generator so it produces valid YAML.

Error: multiple parts found in META.yml

prereq_matches_use

List all used modules in META.yml requires

Error:

  • FCGI
  • HTTP::Status
  • URI
  • WebDyne
  • WebDyne::Base
  • WebDyne::Request::Fake

consistent_version

Split the distribution, or fix the version numbers to make them consistent (use the highest version number to avoid version downgrade).

Error: 1.002,1.021

has_meta_json

Add a META.json to the distribution. Your buildtool should be able to autogenerate it.

meta_yml_has_license

Define the license if you are using in Build.PL. If you are using MakeMaker (Makefile.PL) you should upgrade to ExtUtils::MakeMaker version 6.31.

use_warnings

Add 'use warnings' (or its equivalents) to all modules (this will require perl > 5.6), or convince us that your favorite module is well-known enough and people can easily see the modules warn when something bad happens.

Error: WebDyne::Request::FastCGI, WebDyne::Request::FastCGI::Constant, WebDyne::Request::FastCGI::Run, WebDyne::Request::FastCGI::Static

Modules

Name Abstract Version View
WebDyne::Request::FastCGI FastCGI responder that handles requests for WebDyne pages. 1.021 metacpan
WebDyne::Request::FastCGI::Constant 1.002 metacpan
WebDyne::Request::FastCGI::Run 1.002 metacpan
WebDyne::Request::FastCGI::Static 1.002 metacpan

Other Files

ChangeLog metacpan
MANIFEST metacpan
META.yml metacpan
Makefile.PL metacpan
README metacpan