Kwalitee Issues

meta_yml_conforms_to_known_spec

Take a look at the META.yml Spec at https://metacpan.org/pod/CPAN::Meta::History::Meta_1_4 (for version 1.4) or https://metacpan.org/pod/CPAN::Meta::Spec (for version 2), and change your META.yml accordingly.

Error: Expected a list structure (author) [Validation: 1.3];License '<undef>' is invalid (license) [Validation: 1.3];Missing mandatory field, 'abstract' (abstract) [Validation: 1.3];Missing mandatory field, 'author' (author) [Validation: 1.3];Missing mandatory field, 'license' (license) [Validation: 1.3];value is an undefined string (abstract) [Validation: 1.3]

distname_matches_name_in_meta

Use a proper tool to make a distribution. You might also need to fix META files if you keep them in the repository.

Error: CGI.pm

has_human_readable_license

Add a section called "LICENSE" to the documentation, or add a file named LICENSE to the distribution.

has_license_in_source_file

Add =head1 LICENSE and the text of the license to the main module in your code.

use_strict

Add 'use strict' (or its equivalents) to all modules, or convince us that your favorite module is well-known enough and people can easily see the modules are strictly written.

Error: CGI, CGI::Apache, CGI::Carp, CGI::Cookie, CGI::Fast, CGI::Push, CGI::Switch

no_pod_errors

Remove the POD errors. You can check for POD errors automatically by including Test::Pod to your test suite.

Error: CGI.pm-3.43/CGI.pm -- Around line 5365: Expected text after =item, not a number Around line 5369: Expected text after =item, not a number Around line 5373: Expected text after =item, not a number Around line 5927: Expected text after =item, not a number Around line 5931: Expected text after =item, not a number Around line 5936: Expected text after =item, not a number Around line 5941: Expected text after =item, not a number Around line 6010: Expected text after =item, not a number Around line 6014: Expected text after =item, not a number Around line 6025: Expected text after =item, not a number Around line 6030: Expected text after =item, not a number Around line 6344: Expected text after =item, not a number Around line 6350: Expected text after =item, not a number Around line 6359: Expected text after =item, not a number Around line 6363: Expected text after =item, not a number Around line 6369: Expected text after =item, not a number Around line 6375: Expected text after =item, not a number Around line 6420: Expected text after =item, not a number Around line 6428: Expected text after =item, not a number Around line 6435: Expected text after =item, not a number Around line 6513: Expected text after =item, not a number Around line 6519: Expected text after =item, not a number Around line 6524: Expected text after =item, not a number Around line 6530: Expected text after =item, not a number Around line 6570: Expected text after =item, not a number Around line 6574: Expected text after =item, not a number Around line 6582: Expected text after =item, not a number Around line 6589: Expected text after =item, not a number Around line 6594: Expected text after =item, not a number Around line 6670: Expected text after =item, not a number Around line 6676: Expected text after =item, not a number Around line 6682: Expected text after =item, not a number Around line 6731: Expected text after =item, not a number Around line 6736: Expected text after =item, not a number Around line 6774: Expected text after =item, not a number Around line 6779: Expected text after =item, not a number

meta_yml_declares_perl_version

If you are using Build.PL define the {requires}{perl} = VERSION field. If you are using MakeMaker (Makefile.PL) you should upgrade ExtUtils::MakeMaker to 6.48 and use MIN_PERL_VERSION parameter. Perl::MinimumVersion can help you determine which version of Perl your module needs.

has_meta_json

Add a META.json to the distribution. Your buildtool should be able to autogenerate it.

meta_yml_has_license

Define the license if you are using in Build.PL. If you are using MakeMaker (Makefile.PL) you should upgrade to ExtUtils::MakeMaker version 6.31.

has_known_license_in_source_file

Add =head1 LICENSE and/or the proper text of the well-known license to the main module in your code.

use_warnings

Add 'use warnings' (or its equivalents) to all modules, or convince us that your favorite module is well-known enough and people can easily see the modules warn when something bad happens.

Error: CGI, CGI::Apache, CGI::Carp, CGI::Cookie, CGI::Fast, CGI::Pretty, CGI::Push, CGI::Switch, CGI::Util

consistent_version

Split the distribution, or fix the version numbers to make them consistent (use the highest version number to avoid version downgrade).

Error: 1.04,1.07,1.08,1.29,1.30_01,1.5_01,3.43

meta_yml_has_provides

Add all modules contained in this distribution to the META.yml field 'provides'. Module::Build or Dist::Zilla::Plugin::MetaProvides do this automatically for you.

meta_yml_has_repository_resource

Add a 'repository' resource to the META.yml via 'meta_add' accessor (for Module::Build) or META_ADD parameter (for ExtUtils::MakeMaker).

has_separate_license_file

This is not a critical issue. Currently mainly informative for the CPANTS authors. It might be removed later.

Modules

Name Abstract Version View
CGI Handle Common Gateway Interface requests and responses 3.43 metacpan
CGI::Carp CGI routines for writing to the HTTPD (or other) error log 1.30_01 metacpan
CGI::Cookie Interface to Netscape Cookies 1.29 metacpan
CGI::Fast CGI Interface for Fast CGI 1.07 metacpan
CGI::Pretty module to produce nicely formatted HTML code 1.08 metacpan
CGI::Push Simple Interface to Server Push 1.04 metacpan
CGI::Util Internal utilities used by CGI module 1.5_01 metacpan

Provides

Name File View
CGITempFile CGI.pm metacpan
Fh CGI.pm metacpan
MultipartBuffer CGI.pm metacpan

Other Files

Changes metacpan
MANIFEST metacpan
META.yml metacpan
Makefile.PL metacpan
README metacpan