Kwalitee Issues

use_strict

Add 'use strict' (or its equivalents) to all modules, or convince us that your favorite module is well-known enough and people can easily see the modules are strictly written.

Error: Module::Install::Base

consistent_version

Split the distribution, or fix the version numbers to make them consistent (use the highest version number to avoid version downgrade).

Error: 0.69,1.03

has_meta_json

Add a META.json to the distribution. Your buildtool should be able to autogenerate it.

use_warnings

Add 'use warnings' (or its equivalents) to all modules, or convince us that your favorite module is well-known enough and people can easily see the modules warn when something bad happens.

Error: Module::AutoInstall, Module::Install, Module::Install::Admin, Module::Install::Admin::Bundle, Module::Install::Admin::Find, Module::Install::Admin::Include, Module::Install::Admin::Makefile, Module::Install::Admin::Manifest, Module::Install::Admin::Metadata, Module::Install::Admin::ScanDeps, Module::Install::Admin::WriteAll, Module::Install::Base, Module::Install::Bundle, Module::Install::Can, Module::Install::Compiler, Module::Install::Deprecated, Module::Install::External, Module::Install::Fetch, Module::Install::Include, Module::Install::Inline, Module::Install::MakeMaker, Module::Install::Makefile, Module::Install::Makefile::Name, Module::Install::Makefile::Version, Module::Install::Metadata, Module::Install::PAR, Module::Install::Run, Module::Install::Scripts, Module::Install::Share, Module::Install::Win32, Module::Install::With, Module::Install::WriteAll, inc::Module::Install

meta_yml_has_provides

Add all modules contained in this distribution to the META.yml field 'provides'. Module::Build or Dist::Zilla::Plugin::MetaProvides do this automatically for you.

meta_yml_has_repository_resource

Add a 'repository' resource to the META.yml via 'meta_add' accessor (for Module::Build) or META_ADD parameter (for ExtUtils::MakeMaker).

Modules

Name Abstract Version View
Module::AutoInstall Automatic install of dependencies via CPAN 1.03 metacpan
Module::Install Standalone, extensible Perl module installer 0.69 metacpan
Module::Install::Admin Author-side manager for Module::Install 0.69 metacpan
Module::Install::Admin::Bundle 0.69 metacpan
Module::Install::Admin::Find 0.69 metacpan
Module::Install::Admin::Include 0.69 metacpan
Module::Install::Admin::Makefile 0.69 metacpan
Module::Install::Admin::Manifest 0.69 metacpan
Module::Install::Admin::Metadata 0.69 metacpan
Module::Install::Admin::ScanDeps 0.69 metacpan
Module::Install::Admin::WriteAll 0.69 metacpan
Module::Install::Base Base class for Module::Install extensions 0.69 metacpan
Module::Install::Bundle Bundle distributions along with your distribution 0.69 metacpan
Module::Install::Can Utility functions for capability detection 0.69 metacpan
Module::Install::Compiler Commands for interacting with the C compiler 0.69 metacpan
Module::Install::Deprecated Warnings and help for deprecated commands 0.69 metacpan
Module::Install::External Specify dependencies on external non-Perl things 0.69 metacpan
Module::Install::Fetch 0.69 metacpan
Module::Install::Include 0.69 metacpan
Module::Install::Inline 0.69 metacpan
Module::Install::MakeMaker Extension Rules for ExtUtils::MakeMaker 0.69 metacpan
Module::Install::Makefile 0.69 metacpan
Module::Install::Makefile::Name 0.69 metacpan
Module::Install::Makefile::Version 0.69 metacpan
Module::Install::Metadata 0.69 metacpan
Module::Install::PAR Module::Install Support for PAR::Dist packages 0.69 metacpan
Module::Install::Run 0.69 metacpan
Module::Install::Scripts 0.69 metacpan
Module::Install::Share Install non-code files for use during run-time 0.69 metacpan
Module::Install::Win32 0.69 metacpan
Module::Install::With 0.69 metacpan
Module::Install::WriteAll 0.69 metacpan
inc::Module::Install Module::Install loader 0.69 metacpan

Provides

Name File View
Module::Install::Base::FakeAdmin lib/Module/Install/Base.pm metacpan

Other Files

Changes metacpan
MANIFEST metacpan
META.yml metacpan
Makefile.PL metacpan
README metacpan