Kwalitee Issues

No Core Issues.

consistent_version

Split the distribution, or fix the version numbers to make them consistent (use the highest version number to avoid version downgrade).

Error: 0.36_08,0.77,1.40

has_meta_json

Add a META.json to the distribution. Your buildtool should be able to autogenerate it.

no_unauthorized_packages

Ask the owner of the distribution (the one who released it first, or the one who is designated in x_authority) to give you a (co-)maintainer's permission.

Error:

  • Module::Build
  • Module::Build::Base
  • Module::Build::Compat
  • Module::Build::Config
  • Module::Build::Cookbook
  • Module::Build::Dumper
  • Module::Build::ModuleInfo
  • Module::Build::Notes
  • Module::Build::PPMMaker
  • Module::Build::Platform::Amiga
  • Module::Build::Platform::Default
  • Module::Build::Platform::EBCDIC
  • Module::Build::Platform::MPEiX
  • Module::Build::Platform::MacOS
  • Module::Build::Platform::RiscOS
  • Module::Build::Platform::Unix
  • Module::Build::Platform::VMS
  • Module::Build::Platform::VOS
  • Module::Build::Platform::Windows
  • Module::Build::Platform::aix
  • Module::Build::Platform::cygwin
  • Module::Build::Platform::darwin
  • Module::Build::Platform::os2
  • Module::Build::PodParser
  • Module::Build::Version
  • Module::Build::YAML

use_warnings

Add 'use warnings' (or its equivalents) to all modules, or convince us that your favorite module is well-known enough and people can easily see the modules warn when something bad happens.

Error: Module::Build, Module::Build::Base, Module::Build::Compat, Module::Build::Config, Module::Build::Cookbook, Module::Build::Dumper, Module::Build::ModuleInfo, Module::Build::Notes, Module::Build::PPMMaker, Module::Build::Platform::Amiga, Module::Build::Platform::Default, Module::Build::Platform::EBCDIC, Module::Build::Platform::MPEiX, Module::Build::Platform::MacOS, Module::Build::Platform::RiscOS, Module::Build::Platform::Unix, Module::Build::Platform::VMS, Module::Build::Platform::VOS, Module::Build::Platform::Windows, Module::Build::Platform::aix, Module::Build::Platform::cygwin, Module::Build::Platform::darwin, Module::Build::Platform::os2, Module::Build::PodParser, Module::Build::Version, Module::Build::YAML, inc::latest, inc::latest::private

Modules

Name Abstract Version View
Module::Build Build and install Perl modules 0.36_08 metacpan
Module::Build::Base Default methods for Module::Build 0.36_08 metacpan
Module::Build::Compat Compatibility with ExtUtils::MakeMaker 0.36_08 metacpan
Module::Build::Config 0.36_08 metacpan
Module::Build::Cookbook Examples of Module::Build Usage 0.36_08 metacpan
Module::Build::Dumper 0.36_08 metacpan
Module::Build::ModuleInfo 0.36_08 metacpan
Module::Build::Notes Create persistent distribution configuration modules 0.36_08 metacpan
Module::Build::PPMMaker Perl Package Manager file creation 0.36_08 metacpan
Module::Build::Platform::Amiga Builder class for Amiga platforms 0.36_08 metacpan
Module::Build::Platform::Default Stub class for unknown platforms 0.36_08 metacpan
Module::Build::Platform::EBCDIC Builder class for EBCDIC platforms 0.36_08 metacpan
Module::Build::Platform::MPEiX Builder class for MPEiX platforms 0.36_08 metacpan
Module::Build::Platform::MacOS Builder class for MacOS platforms 0.36_08 metacpan
Module::Build::Platform::RiscOS Builder class for RiscOS platforms 0.36_08 metacpan
Module::Build::Platform::Unix Builder class for Unix platforms 0.36_08 metacpan
Module::Build::Platform::VMS Builder class for VMS platforms 0.36_08 metacpan
Module::Build::Platform::VOS Builder class for VOS platforms 0.36_08 metacpan
Module::Build::Platform::Windows Builder class for Windows platforms 0.36_08 metacpan
Module::Build::Platform::aix Builder class for AIX platform 0.36_08 metacpan
Module::Build::Platform::cygwin Builder class for Cygwin platform 0.36_08 metacpan
Module::Build::Platform::darwin Builder class for Mac OS X platform 0.36_08 metacpan
Module::Build::Platform::os2 Builder class for OS/2 platform 0.36_08 metacpan
Module::Build::PodParser 0.36_08 metacpan
Module::Build::Version 0.77 metacpan
Module::Build::YAML 1.40 metacpan
inc::latest use modules bundled in inc/ if they are newer than installed ones 0.36_08 metacpan
inc::latest::private 0.36_08 metacpan

Other Files

Build.PL metacpan
Changes metacpan
MANIFEST metacpan
META.yml metacpan
Makefile.PL metacpan
README metacpan