Kwalitee Issues

meta_yml_conforms_to_known_spec

Take a look at the META.yml Spec at https://metacpan.org/pod/CPAN::Meta::History::Meta_1_4 (for version 1.4) or https://metacpan.org/pod/CPAN::Meta::Spec (for version 2), and change your META.yml accordingly.

Error: Expected a list structure (author) [Validation: 1.3];License '<undef>' is invalid (license) [Validation: 1.3];Missing mandatory field, 'abstract' (abstract) [Validation: 1.3];Missing mandatory field, 'author' (author) [Validation: 1.3];Missing mandatory field, 'license' (license) [Validation: 1.3];value is an undefined string (abstract) [Validation: 1.3]

no_files_to_be_skipped

Fix MANIFEST.SKIP or use an authoring tool which respects MANIFEST.SKIP. Note that each entry in MANIFEST.SKIP is a regular expression. You may need to add appropriate meta characters not to ignore necessary stuff.

Error: META.yml,build_stuff/generate_SIOCS.pl,build_stuff/sioc_s.txt,config.h.in

use_strict

Add 'use strict' (or its equivalents) to all modules, or convince us that your favorite module is well-known enough and people can easily see the modules are strictly written.

Error: Net::Interface::Developer

no_pod_errors

Remove the POD errors. You can check for POD errors automatically by including Test::Pod to your test suite.

Error: Net-Interface-1.009/Interface.pm -- Around line 340: You can't have =items (as at line 344) unless the first thing after the =over is an =item Around line 363: You can't have =items (as at line 367) unless the first thing after the =over is an =item Around line 387: You can't have =items (as at line 391) unless the first thing after the =over is an =item Around line 476: '=item' outside of any '=over' Around line 850: You forgot a '=back' before '=head1' Net-Interface-1.009/inst/netsymbols.pl -- Around line 667: '=item' outside of any '=over' Around line 695: You forgot a '=back' before '=head1' Around line 712: You forgot a '=back' before '=head1' Net-Interface-1.009/lib/Net/Interface/Developer.pm -- Around line 434: You forgot a '=back' before '=head1'

meta_yml_declares_perl_version

If you are using Build.PL define the {requires}{perl} = VERSION field. If you are using MakeMaker (Makefile.PL) you should upgrade ExtUtils::MakeMaker to 6.48 and use MIN_PERL_VERSION parameter. Perl::MinimumVersion can help you determine which version of Perl your module needs.

has_meta_json

Add a META.json to the distribution. Your buildtool should be able to autogenerate it.

meta_yml_has_license

Define the license if you are using in Build.PL. If you are using MakeMaker (Makefile.PL) you should upgrade to ExtUtils::MakeMaker version 6.31.

use_warnings

Add 'use warnings' (or its equivalents) to all modules, or convince us that your favorite module is well-known enough and people can easily see the modules warn when something bad happens.

Error: Net::Interface, Net::Interface::Developer

consistent_version

Split the distribution, or fix the version numbers to make them consistent (use the highest version number to avoid version downgrade).

Error: 0.02,1.009

meta_yml_has_provides

Add all modules contained in this distribution to the META.yml field 'provides'. Module::Build or Dist::Zilla::Plugin::MetaProvides do this automatically for you.

meta_yml_has_repository_resource

Add a 'repository' resource to the META.yml via 'meta_add' accessor (for Module::Build) or META_ADD parameter (for ExtUtils::MakeMaker).

has_separate_license_file

This is not a critical issue. Currently mainly informative for the CPANTS authors. It might be removed later.

Modules

Name Abstract Version View
Net::Interface Perl extension to access network interfaces 1.009 metacpan
Net::Interface::Developer 0.02 metacpan

Other Files

Changes metacpan
MANIFEST metacpan
META.yml metacpan
Makefile.PL metacpan
README metacpan