Kwalitee Issues

meta_yml_is_parsable

Upgrade your YAML generator so it produces valid YAML.

Error: CPAN::Meta::YAML failed to classify line '{'

meta_json_conforms_to_known_spec

Take a look at the META.json Spec at https://metacpan.org/pod/CPAN::Meta::History::Meta_1_4 (for version 1.4) or https://metacpan.org/pod/CPAN::Meta::Spec (for version 2), and change your META.json accordingly.

Error: Missing mandatory field, 'abstract' (abstract) [Validation: 1.4];value is an undefined string (abstract) [Validation: 1.4]

has_license_in_source_file

Add =head1 LICENSE and the text of the license to the main module in your code.

use_strict

Add 'use strict' (or its equivalents) to all modules, or convince us that your favorite module is well-known enough and people can easily see the modules are strictly written.

Error: AE, AnyEvent, AnyEvent::DNS, AnyEvent::Debug, AnyEvent::Handle, AnyEvent::Impl::EV, AnyEvent::Impl::Event, AnyEvent::Impl::EventLib, AnyEvent::Impl::Glib, AnyEvent::Impl::IOAsync, AnyEvent::Impl::Irssi, AnyEvent::Impl::POE, AnyEvent::Impl::Perl, AnyEvent::Impl::Qt, AnyEvent::Impl::Tk, AnyEvent::Socket, AnyEvent::Strict, AnyEvent::TLS, AnyEvent::Util

no_pod_errors

Remove the POD errors. You can check for POD errors automatically by including Test::Pod to your test suite.

Error: AnyEvent-5.202/lib/AnyEvent/Intro.pod -- Around line 692: Non-ASCII character seen before =encoding in 'Münchhausen'. Assuming UTF-8

meta_yml_declares_perl_version

If you are using Build.PL define the {requires}{perl} = VERSION field. If you are using MakeMaker (Makefile.PL) you should upgrade ExtUtils::MakeMaker to 6.48 and use MIN_PERL_VERSION parameter. Perl::MinimumVersion can help you determine which version of Perl your module needs.

meta_yml_has_license

Define the license if you are using in Build.PL. If you are using MakeMaker (Makefile.PL) you should upgrade to ExtUtils::MakeMaker version 6.31.

has_known_license_in_source_file

Add =head1 LICENSE and/or the proper text of the well-known license to the main module in your code.

use_warnings

Add 'use warnings' (or its equivalents) to all modules, or convince us that your favorite module is well-known enough and people can easily see the modules warn when something bad happens.

Error: AE, AnyEvent, AnyEvent::DNS, AnyEvent::Debug, AnyEvent::Handle, AnyEvent::Impl::EV, AnyEvent::Impl::Event, AnyEvent::Impl::EventLib, AnyEvent::Impl::Glib, AnyEvent::Impl::Irssi, AnyEvent::Impl::POE, AnyEvent::Impl::Perl, AnyEvent::Impl::Qt, AnyEvent::Impl::Tk, AnyEvent::Socket, AnyEvent::Strict, AnyEvent::TLS, AnyEvent::Util

no_invalid_versions

Fix the version numbers so that version::is_lax($version) returns true.

Error:

  • lib/AnyEvent/DNS.pm: HASH(0x55af189e6580)
  • lib/AnyEvent/Handle.pm: HASH(0x55af17fd3058)
  • lib/AnyEvent/Impl/IOAsync.pm: HASH(0x55af18157808)
  • lib/AnyEvent/Impl/Perl.pm: HASH(0x55af189f9770)
  • lib/AnyEvent/Socket.pm: HASH(0x55af183abc30)
  • lib/AnyEvent/TLS.pm: HASH(0x55af189eff38)
  • lib/AnyEvent/Util.pm: HASH(0x55af18837cc0)

meta_yml_has_provides

Add all modules contained in this distribution to the META.yml field 'provides'. Module::Build or Dist::Zilla::Plugin::MetaProvides do this automatically for you.

meta_yml_has_repository_resource

Add a 'repository' resource to the META.yml via 'meta_add' accessor (for Module::Build) or META_ADD parameter (for ExtUtils::MakeMaker).

Modules

Name Abstract Version View
AE simpler/faster/newer/cooler AnyEvent API metacpan
AnyEvent the DBI of event loop programming 5.202 metacpan
AnyEvent::DNS fully asynchronous DNS resolution metacpan
AnyEvent::Debug debugging utilities for AnyEvent metacpan
AnyEvent::Handle non-blocking I/O on file handles via AnyEvent metacpan
AnyEvent::Impl::EV AnyEvent adaptor for EV metacpan
AnyEvent::Impl::Event AnyEvent adaptor for Event metacpan
AnyEvent::Impl::EventLib AnyEvent adaptor for Event::Lib metacpan
AnyEvent::Impl::Glib AnyEvent adaptor for Glib metacpan
AnyEvent::Impl::IOAsync AnyEvent adaptor for IO::Async metacpan
AnyEvent::Impl::Irssi AnyEvent adaptor for Irssi metacpan
AnyEvent::Impl::POE AnyEvent adaptor for POE metacpan
AnyEvent::Impl::Perl Pure-Perl event loop and AnyEvent adaptor for itself metacpan
AnyEvent::Impl::Qt AnyEvent adaptor for Qt metacpan
AnyEvent::Impl::Tk AnyEvent adaptor for Tk metacpan
AnyEvent::Socket useful IPv4 and IPv6 stuff. metacpan
AnyEvent::Strict force strict mode on for the whole process metacpan
AnyEvent::TLS SSLv2/SSLv3/TLSv1 contexts for use in AnyEvent::Handle metacpan
AnyEvent::Util various utility functions. metacpan

Provides

Name File View
AnyEvent::Base lib/AnyEvent.pm metacpan
AnyEvent::CondVar lib/AnyEvent.pm metacpan
AnyEvent::CondVar::Base lib/AnyEvent.pm metacpan
AnyEvent::Debug::shell lib/AnyEvent/Debug.pm metacpan
AnyEvent::Impl::Qt::Io lib/AnyEvent/Impl/Qt.pm metacpan
AnyEvent::Impl::Qt::Timer lib/AnyEvent/Impl/Qt.pm metacpan

Other Files

Changes metacpan
MANIFEST metacpan
META.json metacpan
META.yml metacpan
Makefile.PL metacpan
README metacpan