Kwalitee Issues

no_broken_auto_install

Upgrade the bundled version of Module::Install to at least 0.89, but preferably to the most current release. Alternatively, you can switch to another build system / installer that does not suffer from this problem. (ExtUtils::MakeMaker, Module::Build both of which have their own set of problems.)

use_strict

Add 'use strict' (or its equivalents) to all modules, or convince us that your favorite module is well-known enough and people can easily see the modules are strictly written.

Error: Module::Install::Admin::Include, Module::Install::Admin::WriteAll, Module::Install::Base

consistent_version

Split the distribution, or fix the version numbers to make them consistent (use the highest version number to avoid version downgrade).

Error: 0.64,1.03

has_meta_json

Add a META.json to the distribution. Your buildtool should be able to autogenerate it.

use_warnings

Add 'use warnings' (or its equivalents) to all modules, or convince us that your favorite module is well-known enough and people can easily see the modules warn when something bad happens.

Error: Module::AutoInstall, Module::Install, Module::Install::Admin, Module::Install::Admin::Bundle, Module::Install::Admin::Find, Module::Install::Admin::Include, Module::Install::Admin::Makefile, Module::Install::Admin::Manifest, Module::Install::Admin::Metadata, Module::Install::Admin::ScanDeps, Module::Install::Admin::WriteAll, Module::Install::AutoInstall, Module::Install::Base, Module::Install::Build, Module::Install::Bundle, Module::Install::Can, Module::Install::Compiler, Module::Install::Deprecated, Module::Install::External, Module::Install::Fetch, Module::Install::Include, Module::Install::Inline, Module::Install::MakeMaker, Module::Install::Makefile, Module::Install::Makefile::Name, Module::Install::Makefile::Version, Module::Install::Metadata, Module::Install::PAR, Module::Install::Run, Module::Install::Scripts, Module::Install::Share, Module::Install::Win32, Module::Install::With, Module::Install::WriteAll, inc::Module::Install

has_separate_license_file

This is not a critical issue. Currently mainly informative for the CPANTS authors. It might be removed later.

meta_yml_has_repository_resource

Add a 'repository' resource to the META.yml via 'meta_add' accessor (for Module::Build) or META_ADD parameter (for ExtUtils::MakeMaker).

Modules

Name Abstract Version View
Module::AutoInstall Automatic install of dependencies via CPAN 1.03 metacpan
Module::Install Standalone, extensible Perl module installer 0.64 metacpan
Module::Install::Admin Author-side manager for Module::Install 0.64 metacpan
Module::Install::Admin::Bundle 0.64 metacpan
Module::Install::Admin::Find 0.64 metacpan
Module::Install::Admin::Include 0.64 metacpan
Module::Install::Admin::Makefile 0.64 metacpan
Module::Install::Admin::Manifest 0.64 metacpan
Module::Install::Admin::Metadata 0.64 metacpan
Module::Install::Admin::ScanDeps 0.64 metacpan
Module::Install::Admin::WriteAll 0.64 metacpan
Module::Install::AutoInstall 0.64 metacpan
Module::Install::Base Base class for Module::Install extensions 0.64 metacpan
Module::Install::Base::FakeAdmin metacpan
Module::Install::Build Extension Rules for Module::Build 0.64 metacpan
Module::Install::Bundle Bundle distributions along with your distribution 0.64 metacpan
Module::Install::Can Utility functions for capability detection 0.64 metacpan
Module::Install::Compiler Commands for interacting with the C compiler 0.64 metacpan
Module::Install::Deprecated Warnings and help for deprecated commands 0.64 metacpan
Module::Install::External Specify dependencies on external non-Perl things 0.64 metacpan
Module::Install::Fetch 0.64 metacpan
Module::Install::Include 0.64 metacpan
Module::Install::Inline 0.64 metacpan
Module::Install::MakeMaker Extension Rules for ExtUtils::MakeMaker 0.64 metacpan
Module::Install::Makefile 0.64 metacpan
Module::Install::Makefile::Name 0.64 metacpan
Module::Install::Makefile::Version 0.64 metacpan
Module::Install::Metadata 0.64 metacpan
Module::Install::PAR Module::Install Support for PAR::Dist packages 0.64 metacpan
Module::Install::Run 0.64 metacpan
Module::Install::Scripts 0.64 metacpan
Module::Install::Share Install non-code files for use during run-time 0.64 metacpan
Module::Install::Win32 0.64 metacpan
Module::Install::With 0.64 metacpan
Module::Install::WriteAll 0.64 metacpan
inc::Module::Install Module::Install loader 0.64 metacpan

Other Files

Changes metacpan
MANIFEST metacpan
META.yml metacpan
Makefile.PL metacpan
README metacpan