Kwalitee Issues

main_module_version_matches_dist_version

Make sure that the main module name and version are the same of the distribution.

no_pax_headers

If you use Mac OS X >= 10.6, use gnu tar (/usr/bin/gnutar) to avoid PAX headers. It's also important to rename (shorten) long file names (>= 100 characters) in the distribution.

Error: OpenTracing-Role-0.03/PaxHeader/Makefile.PL,OpenTracing-Role-0.03/PaxHeader/Makefile.PL,OpenTracing-Role-0.03/lib/OpenTracing/Role/PaxHeader/Tracer.pm,OpenTracing-Role-0.03/lib/OpenTracing/Role/PaxHeader/Tracer.pm,OpenTracing-Role-0.03/lib/OpenTracing/Role/PaxHeader/SpanContext.pm,OpenTracing-Role-0.03/lib/OpenTracing/Role/PaxHeader/SpanContext.pm,OpenTracing-Role-0.03/lib/OpenTracing/Role/PaxHeader/Scope.pm,OpenTracing-Role-0.03/lib/OpenTracing/Role/PaxHeader/Scope.pm,OpenTracing-Role-0.03/lib/OpenTracing/Role/PaxHeader/ScopeManager.pm,OpenTracing-Role-0.03/lib/OpenTracing/Role/PaxHeader/ScopeManager.pm,OpenTracing-Role-0.03/lib/OpenTracing/Role/PaxHeader/Span.pm,OpenTracing-Role-0.03/lib/OpenTracing/Role/PaxHeader/Span.pm,OpenTracing-Role-0.03/lib/OpenTracing/Role/PaxHeader/GlobalTracer.pm,OpenTracing-Role-0.03/lib/OpenTracing/Role/PaxHeader/GlobalTracer.pm

use_strict

Add 'use strict' (or its equivalents) to all modules, or convince us that your favorite module is well-known enough and people can easily see the modules are strictly written.

Error: OpenTracing::Role::GlobalTracer

meta_yml_declares_perl_version

If you are using Build.PL define the {requires}{perl} = VERSION field. If you are using MakeMaker (Makefile.PL) you should upgrade ExtUtils::MakeMaker to 6.48 and use MIN_PERL_VERSION parameter. Perl::MinimumVersion can help you determine which version of Perl your module needs.

use_warnings

Add 'use warnings' (or its equivalents) to all modules, or convince us that your favorite module is well-known enough and people can easily see the modules warn when something bad happens.

Error: OpenTracing::Role::GlobalTracer

meta_yml_has_provides

Add all modules contained in this distribution to the META.yml field 'provides'. Module::Build or Dist::Zilla::Plugin::MetaProvides do this automatically for you.

meta_yml_has_repository_resource

Add a 'repository' resource to the META.yml via 'meta_add' accessor (for Module::Build) or META_ADD parameter (for ExtUtils::MakeMaker).

Modules

Name Abstract Version View
OpenTracing::Role::Scope Role for OpenTracing implementations. metacpan
OpenTracing::Role::ScopeManager Role for OpenTracing implementations. metacpan
OpenTracing::Role::Span Role for OpenTracing implementations. metacpan
OpenTracing::Role::SpanContext Role for OpenTracing implementations. metacpan
OpenTracing::Role::Tracer Role for OpenTracin implementations. metacpan

Other Files

MANIFEST metacpan
META.json metacpan
META.yml metacpan
Makefile.PL metacpan
README.md metacpan
cpanfile metacpan