Kwalitee Issues

has_license_in_source_file

Add =head1 LICENSE and the text of the license to the main module in your code.

main_module_version_matches_dist_version

Fix the version(s).

manifest_matches_dist

Run a proper command ("make manifest" or "./Build manifest", maybe with a force option), or use a distribution builder to generate the MANIFEST. Or update MANIFEST manually.

Error:

  • MANIFEST (71) does not match dist (43):
  • Missing in Dist: templates/bits/podview/html/command-back-bullet, templates/bits/podview/html/command-back-number, templates/bits/podview/html/command-back-text, templates/bits/podview/html/command-head1, templates/bits/podview/html/command-head2, templates/bits/podview/html/command-item-bullet, templates/bits/podview/html/command-item-number, templates/bits/podview/html/command-item-text, templates/bits/podview/html/command-over-bullet, templates/bits/podview/html/command-over-number, templates/bits/podview/html/command-over-text, templates/bits/podview/html/command-unknown, templates/bits/podview/html/embed-bold, templates/bits/podview/html/embed-code, templates/bits/podview/html/embed-escape, templates/bits/podview/html/embed-file, templates/bits/podview/html/embed-italic, templates/bits/podview/html/embed-link-man, templates/bits/podview/html/embed-link-pod, templates/bits/podview/html/embed-link-url, templates/bits/podview/html/embed-nbsp, templates/bits/podview/html/embed-unknown, templates/bits/podview/html/textblock-start, templates/bits/podview/html/textblock-stop, templates/bits/podview/html/textblock-text, templates/bits/podview/html/verbatim-start, templates/bits/podview/html/verbatim-stop, templates/bits/podview/html/verbatim-text

consistent_version

Split the distribution, or fix the version numbers to make them consistent (use the highest version number to avoid version downgrade).

Error: 1.05,1.9

has_known_license_in_source_file

Add =head1 LICENSE and/or the proper text of the well-known license to the main module in your code.

has_tests_in_t_dir

Add tests or move tests.pl to the t/ directory!

meta_yml_declares_perl_version

If you are using Build.PL define the {requires}{perl} = VERSION field. If you are using MakeMaker (Makefile.PL) you should upgrade ExtUtils::MakeMaker to 6.48 and use MIN_PERL_VERSION parameter. Perl::MinimumVersion can help you determine which version of Perl your module needs.

meta_yml_has_license

Define the license if you are using in Build.PL. If you are using MakeMaker (Makefile.PL) you should upgrade to ExtUtils::MakeMaker version 6.31.

use_warnings

Add 'use warnings' (or its equivalents) to all modules (this will require perl > 5.6), or convince us that your favorite module is well-known enough and people can easily see the modules warn when something bad happens.

Error: XAO::DO::Web::PodView, XAO::DO::Web::PodView::Parser, testcases::PodView::WebPodView, testcases::PodView::base

meta_yml_has_provides

Add all modules contained in this distribution to the META.yml field 'provides'. Module::Build or Dist::Zilla::Plugin::MetaProvides do this automatically for you.

meta_yml_has_repository_resource

Add a 'repository' resource to the META.yml via 'meta_add' accessor (for Module::Build) or META_ADD parameter (for ExtUtils::MakeMaker).

Modules

Name Abstract Version View
XAO::DO::Web::PodView POD files viewer for XAO::Web 1.05 metacpan
XAO::DO::Web::PodView::Parser POD parser for XAO::DO::Web::PodView 1.9 metacpan
testcases::PodView::WebPodView metacpan
testcases::PodView::base metacpan

Other Files

MANIFEST metacpan
META.json metacpan
META.yml metacpan
Makefile.PL metacpan
README metacpan