Kwalitee Indicator: no_broken_module_install core

This distribution uses an obsolete version of Module::Install. Versions of Module::Install prior to 0.61 might not work on some systems at all. Additionally if your Makefile.PL uses the 'auto_install()' feature, you need at least version 0.64. Also, 1.04 is known to be broken.

How to fix

Upgrade the bundled version of Module::Install to the most current release. Alternatively, you can switch to another build system / installer that does not suffer from this problem. (ExtUtils::MakeMaker, Module::Build both of which have their own set of problems.)

Yearly Statistics

Year Fails (Latest) Releases (Latest) Fails (CPAN) Releases (CPAN) Fails (BackPAN) Releases (BackPAN)
2019 1 1212 1 1889 2 2267
2018 1 3923 2 10236 2 15504
2017 1 3640 2 10081 2 16360
2016 2 3164 2 9765 3 19982
2015 0 3201 0 10810 2 22999
2014 0 3319 3 11537 15 27272
2013 5 3148 20 11082 31 25760
2012 70 2579 325 9319 624 22647
2011 37 2508 202 8958 347 21910
2010 2 2536 1 7846 3 22227

Latest Fails

Name Released by Released on
Alien-SeleniumRC-3.7 HISSO 2019-02-08
Test-Time-0.07 SATOH 2018-09-27
XML-DOM-Lite-0.16 RHUNDT 2017-06-03
Net-SAML2-0.18_02 JBONNEY 2016-09-13
ExtUtils-AutoInstall-0.64 INGY 2016-09-13
SRS-EPP-Proxy-0.22 MUTANT 2013-04-24
RT-Extension-CustomerGroups-1.00 RINGERC 2013-04-08
SMS-Send-RedOxygen-1.06 RINGERC 2013-03-21
Config-Multi-0.12 TARO 2013-03-10
RT-Extension-ArticleSubjectOverride-0.02 TSIBLEY 2013-01-18
Test-Attribute-AutoLevel-0.06 NEKOKAK 2012-12-26
FormValidator-LazyWay-0.20 TARO 2012-12-25
Sub-Mage-0.032 BRADH 2012-12-08
Text-Overflow-0.02 SATOH 2012-11-26
CPAN-Inject-1.14 PSHANGOV 2012-09-13
RT-Condition-NotStartedInBusinessHours-0.3 BHEISIG 2012-09-12
WWW-Asg-0.05 FUKATA 2012-08-31
Text-MarkPerl-0.1 MUCKER 2012-08-06
HTTP-MobileAgent-0.36 KURIHARA 2012-07-24
RT-Extension-DateTAI64-0.01 FALCONE 2012-07-12
Acme-Greeting-0.0.3 GUGOD 2012-07-03
HTML-JQuery-0.005 BRADH 2012-05-16
WWW-Giraffi-API-0.2_04 HOLLY 2012-05-11
Finance-TW-TSEQuote-0.28 CLKAO 2012-04-24
Authen-Simple-0.5 CHANSEN 2012-04-20